XML for ConceptDraw schema

<ConceptDrawDocument>

<DocumentProperties>
<BuildNumberCreated/>
<BuildNumberEdited/>
 <Title/>
<Subject/>
<Author/>
<Company/>
<Desc/>
<DocumentSettings>
<Units/>
 <Scale/>
 <UndoDepth/>
<SnapSensitivity/>
<SnapSettings/>
<GlueSettings/>
<ShadowOffset/>
</DocumentSettings>
<PageSettings>
<PageSizeType/>
<PageWidth/>
<PageHeight/>
</PageSettings>
<DefaultSettings>
<LinePen/>
<LineBegin/>
<LineEnd/>
<LineEndsSize/>
<Fill/>
<Shadow/>
<Paragraph/>
<Character/>
<TextBlock/>
<ActiveLayer/>
</DefaultSettings>
</DocumentProperties>

<PrintSetup>
<PrintSize/>
 <Justification/>
 <PlacementMethod/>
<PaperOrientation/>
<PaperSize/>
<PaperWidth/>
<PaperHeight/>
<PageTopMargin/>
<PageBottomMargin/>
<PageLeftMargin/>
<PageRightMargin/>
</PrintSetup>

<Layers>
<Layer/>
 </Layers>

 <Pages>
<Page>
<Shapes>
<Shape/>
</Shapes>
<Services>
<ServObj/>
</Services>
</Page>
</Pages>

<IndexDecoder>
<ColorPalette>
<ColorEntry/>
</ColorPalette>
<Fonts>
<FontEntry/>
</Fonts>
<HyperLinks>
<HyperlinkEntry/>
</HyperLinks>
</IndexDecoder>

 <Resources>
<ResData/>
</Resources>

</ConceptDrawDocument>


XML for ConceptDraw element reference

XML for ConceptDraw
Element Reference

A B C D E F G H I J L M N O P R S T U V W X Y

<A> element

Specifies an x-coordinate on a shape in local coordinates. The following table describes the X element based on the element that contains it.

Element | Description of X element
ArcTo EllipseTo SplineStart SplineKnot | The X element represents the x-coordinates of the control point of a circular arc segment. The X element represents the x-coordinates of the control point of a elliptical arc segment. The X element represents the x-coordinates of the spline guide point (control point). The X element represents the x-coordinates of the spline guide point (control point).

Syntax

 <A
[Unit = "unitval"]
[F = "formula"]
[Err = "error"]>
doubleval
</A>

Attributes

Unit
Optional string. Represents the unit of measure in which the value is specified. It can take one of the values from the "Abbreviation for use" column from the table of the supported units of measure. The default value is the ConceptDraw internal measurement unit: 1 = 0.1 mm.
F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 8 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: ArcTo, EllipseTo, SplineStart, SplineKnot

Child elements: None

<Act> element

Defines custom command names that appear on an object's shortcut menu and specifies the actions that the commands take.

Syntax

 <Act
[IX = "intval"]>
</Act>

Attributes

 IX
Optional int. The one-based index of the element within its parent element.

Element information

 Parent elements: Actions

Child elements: Action (optional), Menu (optional), Prompt (optional), Checked (optional),
Disabled (optional)

<Action> element

Contains the formula to execute when a user clicks the command name defined in the corresponding Menu element.

Syntax

 <Action
[F = "formula"]
[Err = "error"]>
byteval
</Action>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 8 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Act

Child elements: None

Remarks
The formula in an Action element is evaluated only when the action occurs, not when the formula is entered into the element.

<Actions> element

Contains a list of the Act elements describing the actions of user's context menu for the given shape.

Syntax

 <Actions>
</Actions>

Attributes

 None.

Element information

 Parent elements: Shape

Child elements: Act (optional)

<ActiveLayer> element

Contains the index of the active layer in the document.

Syntax

 <ActiveLayer>
intval
</ActiveLayer>

Attributes

 None.

Element information

 Parent elements: DefaultSettings

Child elements: None

<Angle> element

Represents the shape's or service object's current angle of rotation in relation to its parent.

Syntax

 <Angle
[Unit = "unitval"]
[F = "formula"]
[Err = "error"]>
doubleval
</Angle>

Attributes

Unit
Optional string. Represents the unit of measure in which the value is specified. It can take one of the following values: rad - radians, grad - degrees. The default value is rad.
 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 3.14 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Transform , ServObj

Child elements: None

<ArcTo> element

Contains elements that specify information about an circular arc.
The X and Y elements specify the x- and y-coordinates of the ending vertex on the arc. The A and B elements specify the x- and y-coordinates of the arc's control point.

Syntax

 <ArcTo
[IX = "intval"]>
</ArcTo>

Attributes

 IX
Optional int. The one-based index of the element within its parent element. If the index is not specified, it is obtained by incrementing the maximum index of the existing segments in the current geometry. If the given index already exists, all the child elements will modify the existing segment.

Element information

 Parent elements: Geom

Child elements: X (optional), Y (optional), A (optional), B (optional)

<Author> element

Contains a user-defined text string identifying the author of the document or library.

Syntax

 <Author>
strval
</Author>

Attributes

 None.

Element information

 Parent elements: DocumentProperties

Child elements: None

<B> element

Specifies an y-coordinate on a shape in local coordinates. The following table describes the Y element based on the element that contains it.

Element | Description of Y element
ArcTo EllipseTo SplineStart SplineKnot | The Y element represents the y-coordinates of the control point of a circular arc segment. The Y element represents the y-coordinates of the control point of a elliptical arc segment. The Y element represents the y-coordinates of the spline guide point (control point). The Y element represents the y-coordinates of the spline guide point (control point).

Syntax

 <B
[Unit = "unitval"]
[F = "formula"]
[Err = "error"]>
doubleval
</B>

Attributes

Unit
Optional string. Represents the unit of measure in which the value is specified. It can take one of the values from the "Abbreviation for use" column from the table of the supported units of measure. The default value is the ConceptDraw internal measurement unit: 1 = 0.1 mm.
F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 8 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: ArcTo, EllipseTo, SplineStart, SplineKnot

Child elements: None

<BeginX> element

Represents the x-coordinate of the begin point of the 1-D shape, in relation to the origin of its parent.

Syntax

 <BeginX
[Unit = "unitval"]
[F = "formula"]
[Err = "error"]>
doubleval
</BeginX>

Attributes

Unit
Optional string. Represents the unit of measure in which the value is specified. It can take one of the values from the "Abbreviation for use" column from the table of the supported units of measure. The default value is the ConceptDraw internal measurement unit: 1 = 0.1 mm.
F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 8 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: EndPoints

Child elements: None

<BeginY> element

Represents the y-coordinate of the begin point of the 1-D shape, in relation to the origin of its parent.

Syntax

 <BeginY
[Unit = "unitval"]
[F = "formula"]
[Err = "error"]>
doubleval
</BeginY>

Attributes

Unit
Optional string. Represents the unit of measure in which the value is specified. It can take one of the values from the "Abbreviation for use" column from the table of the supported units of measure. The default value is the ConceptDraw internal measurement unit: 1 = 0.1 mm.
F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 8 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: EndPoints

Child elements: None

<BottomMargin> element

Determines the distance between the bottom border of the text block and the last line of text it contains.

Syntax

 <BottomMargin
[F = "formula"]
[Err = "error"]>
floatval
</BottomMargin>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 8 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: TextBlock

Child elements: None

<BuildNumberCreated> element

Contains the full build number of the instance used to create the document.

Syntax

 <BuildNumberCreated>
intval
</BuildNumberCreated>

Attributes

 None.

Element information

 Parent elements: DocumentProperties

Child elements: None

Remarks

The format of the full build number, which includes both build and revision information, is described in the following table.

Digit place | Description
1..3 4..5 6 and > | Internal revision number. Minor version number. Major version number.

Example: For a document created with ConceptDraw v1.7.5 , the build number may look like this:
<BuildNumberCreated>175000</BuildNumberCreated>

<BuildNumberEdited> element

Contains the build number of the instance last used to edit the document.

Syntax

 <BuildNumberEdited>
intval
</BuildNumberEdited>

Attributes

 None.

Element information

 Parent elements: DocumentProperties

Child elements: None

Remarks

The format of the full build number, which includes both build and revision information, is described in the following table.

Digit place | Description
1..3 4..5 6 and > | Internal revision number. Minor version number. Major version number.

Example: If the document has been edited with ConceptDraw v1.7.5 , then its build number may look like this:
<BuildNumberEdited>175000</BuildNumberEdited>

<C> element

Specifies the ratio of an arc's major axis to its minor axis.

Syntax

 <C
[F = "formula"]
[Err = "error"]>
doubleval
</C>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 8 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: EllipseTo

Child elements: None

<Character> element

Contains the formatting attributes for the shape's text, such as font, color, text style, spacing, hyperlink, position relative to the baseline, and point size.

Syntax

 <Character
[IX = "intval"]
[CharCount = "intval"]
</Character>

Attributes

IX
 Optional int. The zero-based index of the element within its parent element.
CharCount
Optional int. The number of characters contained in the given Character element. The default value is 0.

Element information

 Parent elements: Text , DefaultSettings

Child elements: Font (optional), Size (optional), Color (optional), CharStyle (optional), Language (optional), Pos (optional)

<CharStyle> element

Specifies the character formatting applied to a range of text in the shape's text block.
The value represents a binary number in which each bit indicates a character style. For example, a value of 3 represents text formatted in both italic and bold. If the value of CharStyle is 0, the text is plain, or unformatted.

Value | Description
1 2 4 8 16 32 64 128 | Bold Italic Underline Strikeout Outline Shadow Condense Extend

Syntax

 <CharStyle
[F = "formula"]
[Err = "error"]>
intval
</CharStyle>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 8 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Character

Child elements: None

<Checked> element

Determines whether a check mark is displayed beside the command name on a shape's shortcut menu.

Value | Description
0 1 | Check mark is not displayed. Check mark is displayed.

Syntax

 <Checked
[F = "formula"]
[Err = "error"]>
boolval
</Checked>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 0 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Act

Child elements: None

<ColorEntry> element

Determines the color of one element in the palette.
The color can be identified according to different color schemes.
The color is determined by specifying its components. The two color schemes are supported: RGB and CMYK.
Thus the colorval is expressed by a string and takes the following possible values:

'RGB(red,green,blue)'
'RGBA(red,green,blue,alpha)'
'CMYK(cyan,magenta,yellow,black)'
'CMYKA(cyan,magenta,yellow,black,alpha)'

here red,green,blue are integers within the (0 .. 255) range which define the color components for the RGB scheme;
cyan,magenta,yellow,black are integers within the (0 .. 100) range, defining the color components for the CMYK scheme;
alpha is integer within (0 .. 1), setting the transparence: 1 corresponds to transparent, and 0 to oblique.

Syntax

 <ColorEntry
[IX = "intval"]>
colorval
</ColorEntry>

Attributes

 IX
Optional int. The zero-based index of the element within its parent element. Generally, the index shows the number of the color in the ConceptDraw palette. If the index is not specified, it is obtained by incrementing the index of the previous ColorEntry. If the index coincides with that of another color already specified in the palette, this color gets the new value.

Element information

 Parent elements: ColorPalette

Child elements: None

<ColorPalette> element

Describes the color palette used in the ConceptDraw document. It contains a number of ColorEntry elements identifying the indexed elements of the color palette.

Syntax

 <ColorPalette>
</ColorPalette>

Attributes

 None.

Element information

 Parent elements: IndexDecoder

Child elements: ColorEntry (optional)

Remarks
ConceptDraw supports palettes containing up to 256 colors. So, the ColorPalette element may contain up to 256 ColorEntry elements numbered from 0 to 255. If the ColorEntry for some number is not specified, the corresponding default color remains in the palette.

<Comment> element

Contains a string with the tip for the control handle.

Syntax

 <Comment
[F = "formula"]
[Err = "error"]>
strval
</Comment>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> "comment" </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Control

Child elements: None

<Company> element

Contains user-entered information identifying the company creating the document/library or the company the document/library is being created for.

Syntax

 <Company>
strval
</Company>

Attributes

 None.

Element information

 Parent elements: DocumentProperties

Child elements: None

<ConceptDrawDocument> element

The root element of a ConceptDraw document.

Syntax

 <ConceptDrawDocument
[Version = "intval"]
[Template = "strval"]>
</ConceptDrawDocument>

Attributes

 Version
Optional int. This is the version of XML format for ConceptDraw. It is represented by a decimal integer, with digits coding the version: the units digit stands for the second minor number of the version, the tens digit is the first minor number, the rest digits (hundreds and upper) show the major version number.
Example: The firmat version 1.0.2 is coded as "102". The default Version value is "100".
Template
Optional string. Contains a string value specifying the file name of the template from which the document must be created. A template is a ConceptDraw file which is used to store the desired set of default settings for new documents (measurement system, grid spacing, page size etc.), the list of libraries to open, and a sample document.

Element information

 Parent elements: None

Child elements: DocumentProperties (optional), PrintSetup (optional), Layers (optional),Pages (optional), IndexDecoder (optional), Resources (optional)

<ConnectBegin> element

Contains the ID of the shape object to which the current shape is connected by its begin point.

Syntax

 <ConnectBegin
[F = "formula"]
[Err = "error"]>
intval
</ConnectBegin>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 8 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: ConnectInfo

Child elements: None

<ConnectEnd> element

Contains the ID of the shape object to which the current shape is connected by its end point.

Syntax

 <ConnectEnd
[F = "formula"]
[Err = "error"]>
intval
</ConnectEnd>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 8 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: ConnectInfo

Child elements: None

<ConnectInfo> element

Describes to which object and in what way the given shape is connected by its endpoints (Begin and End). This element appears for 1-D shapes only. The absence of this element means that the shape is not cinnected to any object by either of its endpoints.

Syntax

 <ConnectInfo>
</ConnectInfo>

Attributes

 None.

Element information

 Parent elements: Shape

Child elements: ConnectBegin (optional), ConnectEnd (optional), ConnectTypeBegin (optional), ConnectTypeEnd (optional)

<Connection> element

Contains elements for one connection point defined for the shape.

Syntax

 <Connection
[IX = "intval"]>
</Connection>

Attributes

 IX
Optional int. The one-based index of the element within its parent element.

Element information

 Parent elements: Connections

Child elements: X (optional), Y (optional)

<Connections> element

Contains a set of the Connection elements describing the connection points of the shape.

Syntax

 <Connections>
</Connections>

Attributes

 None.

Element information

 Parent elements: Shape

Child elements: Connection (optional)

<ConnectTypeBegin> element

Contains the type of connection fulfilled by the begin point of the current shape. This element may take the following preset values: Left, Top, Right, Bottom, Centre.

Syntax

 <ConnectTypeBegin
[F = "formula"]
[Err = "error"]>
intval
</ConnectTypeBegin>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 8 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: ConnectInfo

Child elements: None

<ConnectTypeEnd> element

Contains the type of connection fulfilled by the end point of the current shape. This element may take the following preset values: Left, Top, Right, Bottom, Centre.

Syntax

 <ConnectTypeEnd
[F = "formula"]
[Err = "error"]>
intval
</ConnectTypeEnd>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 8 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: ConnectInfo

Child elements: None

<Control> element

Contains elements for the x- and y-coordinates of each control handle defined for a shape, and elements that specify the way the control handle should behave.

Syntax

 <Control
[IX = "intval"]>
</Control>

Attributes

 IX
Optional int. The one-based index of the element within its parent element.

Element information

 Parent elements: Controls

Child elements: X (optional), Y (optional), XDyn (optional), YDyn (optional),
XBehaviour (optional), YBehaviour (optional), Comment (optional)

<Controls> element

Contains a set of Control elements describing the control handles of the shape.

Syntax

 <Controls>
</Controls>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 8 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Shape

Child elements: Control (optional)

<D> element

Specifies the angle of the arc's major axis relative to the x-axis of its parent.

Syntax

 <D
[Unit = "unitval"]
[F = "formula"]
[Err = "error"]>
doubleval
</D>

Attributes

Unit
Optional string. Represents the unit of measure in which the element's value is specified. It can take one of the following values: rad - radians, grad - degrees. The default value is rad.
F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 8 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: EllipseTo

Child elements: None

<DblClick> element

Defines the reaction to double-clicking the given shape. It may take the following values:

Value | Description
0 1 2 3 4 5 6 | Perform no action. Edit Shape's text. Edit Shape's table. Open group in new window. Go to hyperlink target. OLE Verb. Perform action.

Syntax

 <DblClick
[F = "formula"]
[Err = "error"]>
intval
</DblClick>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 6 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Shape

Child elements: None

<DefaultSettings> element

Contains the default property elements for the shapes created: LinePen, LineBegin, LineEnd, Fill, Shadow, Paragraph, Character, TextBlock, ActiveLayer, DefStyle.

Syntax

 <DefaultSettings>
</DefaultSettings>

Attributes

 None.

Element information

 Parent elements: DocumentProperties

Child elements: LinePen (optional), LineBegin (optional), LineEnd (optional), LineEndsSize (optional), Fill (optional), Shadow (optional), Paragraph (optional), Character (optional), TextBlock (optional), ActiveLayer (optional)

<Desc> element

Contains a descriptive text string for a document/library/shape/service object. Use this element to store important information about the document/library/shape/service object, such as its purpose, recent changes, or pending changes.

Syntax

 <Desc>
strval
</Desc>

Attributes

 None.

Element information

 Parent elements: DocumentProperties , Shape , ServObj

Child elements: None

<Disabled> element

Specifies the display of the command name on the shortcut menu.

Value | Description
0 1 | Enable (highlight) command name. Disable (dim) command name.

Syntax

 <Disabled
[F = "formula"]
[Err = "error"]>
boolval
</Disabled>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 0 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Act

Child elements: None

<DocumentProperties> element

Contains document property elements such as the title and author of the document, etc.

Syntax

 <DocumentProperties>
</DocumentProperties>

Attributes

 None.

Element information

 Parent elements: ConceptDrawDocument

Child elements: BuildNumberCreated (optional), BuildNumberEdited (optional), Title (optional), Subject (optional), Author (optional), Company (optional), Desc (optional), DocumentSettings (optional), PageSettings (optional), DefaultSettings (optional)

<DocumentSettings> element

Contains elements that specify document settings.

Syntax

 <DocumentSettings>
</DocumentSettings>

Attributes

 None.

Element information

 Parent elements: DocumentProperties

Child elements: Units (optional), Scale (optional), UndoDepth (optional), SnapSensitivity (optional), SnapSettings (optional), GlueSettings (optional), ShadowOffset (optional)

<EllipseTo> element

Contains elements that specify information about an elliptical arc.
The X and Y elements specify the x- and y-coordinates of the ending vertex on the arc. The A and B elements specify the x- and y-coordinates of the arc's control point. The C element specifies the ratio of an arc's major axis to its minor axis. The D element specifies the angle of the arc's major axis i relation to the x-axis of its parent.

Syntax

 <EllipseTo
[IX = "intval"]>
</EllipseTo>

Attributes

 IX
Optional int. The one-based index of the element within its parent element. If the index is not specified, it is obtained by incrementing the maximum index of the existing segments in the current geometry. If the given index already exists, all the child elements will modify the existing segment.

Element information

 Parent elements: Geom

Child elements: X (optional), Y (optional), A (optional), B (optional), C (optional), D (optional)

<EndPoints> element

Contains x- and y-coordinates of the begin point and end point of a 1-D shape. This element appears for 1-D shapes only.

Syntax

 <EndPoints>
</EndPoints>

Attributes

 None.

Element information

 Parent elements: Shape

Child elements: BeginX (optional), BeginY (optional), EndX (optional), EndY (optional)

<EndX> element

Represents the x-coordinate of the end point of the 1-D shape, in relation to the origin of its parent.

Syntax

 <EndX
[Unit = "unitval"]
[F = "formula"]
[Err = "error"]>
doubleval
</EndX>

Attributes

Unit
Optional string. Represents the unit of measure in which the value is specified. It can take one of the values from the "Abbreviation for use" column from the table of the supported units of measure. The default value is the ConceptDraw internal measurement unit: 1 = 0.1 mm.
F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 8 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: EndPoints

Child elements: None

<EndY> element

Represents the y-coordinate of the end point of the 1-D shape, in relation to the origin of its parent.

Syntax

 <EndY
[Unit = "unitval"]
[F = "formula"]
[Err = "error"]>
doubleval
</EndY>

Attributes

Unit
Optional string. Represents the unit of measure in which the value is specified. It can take one of the values from the "Abbreviation for use" column from the table of the supported units of measure. The default value is the ConceptDraw internal measurement unit: 1 = 0.1 mm.
F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 8 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: EndPoints

Child elements: None

<EnhMetaFile> element

Contains a MIME (Multipurpose Internet Mail Extensions) encoded BLOB of Enhanced MetaFile data.
In this case, the Base64 encoding is used.

Syntax

 <EnhMetaFile>
blob
</EnhMetaFile>

Attributes

 None.

Element information

 Parent elements: ResData

Child elements: None

<Fill>, <Shadow> elements

Contains the current fill formatting values for the shape or the shape's drop shadow, including pattern, pattern color, and background color.

Syntax

 <Fill
</Fill>

Attributes

 None.

Element information

 Parent elements: FillFormat, DefaultSettings

Child elements: Color (optional), Pattern (optional), PatColor (optional)

<Filled> element

Specifies whether a path can be filled.

Value | Description
0 1 | The path is not filled, even if other paths in the shape are filled. The shape's fill applies to the path, even if it isn't closed.

Syntax

 <Filled
[F = "formula"]
[Err = "error"]>
boolval
</Filled>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 1 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Geom

Child elements: None

<FillFormat> element

Contains the fill property elements for the Shape's geometries and their shadows.

Syntax

 <FillFormat
</FillFormat>

Attributes

 None.

Element information

 Parent elements: Shape

Child elements: Fill (optional), Shadow (optional)

<FirstInd> element

Specifies the distance the first line of each paragraph in the shape's text block is indented from the left indent of the paragraph. This value is independent of the scale of the drawing. If the drawing is scaled, the first line indent remains the same.

Syntax

 <FirstInd
[F = "formula"]
[Err = "error"]>
floatval
</FirstInd>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 8 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Paragraph

Child elements: None

<FlipX> element

Indicates whether the shape has been flipped horizontally.

Value | Description
0 1 | The shape has not been flipped horizontally. The shape has been flipped horizontally.

Syntax

 <FlipX
[F = "formula"]
[Err = "error"]>
boolval
</FlipX>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 1 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Transform

Child elements: None

<FlipY> element

Indicates whether the shape has been flipped vertically.

Value | Description
0 1 | The shape has not been flipped vertically. The shape has been flipped vertically.

Syntax

 <FlipY
[F = "formula"]
[Err = "error"]>
boolval
</FlipY>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 1 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Transform

Child elements: None

<Font> element

Specifies the ID number of the font used to format the text.

Syntax

 <Font
[F = "formula"]
[Err = "error"]>
intval
<Font/>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 8 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Character

Child elements: None

Remarks
Font ID numbers vary according to the fonts installed on the user's system. The ID number corresponds to the ID attribute of a FontEntry element in the document's font table (contained in the Fonts element). The number 0 represents the default font.

<FontEntry> element

Contains the name of a font used in the ConceptDraw document.

Syntax

 <FontEntry
[IX = "intval"]>
strval
</FontEntry>

Attributes

 IX
Optional int. The one-based index of the element within its parent element. If the index is not specified, it is obtained by incrementing the index of the previous FontEntry.

Element information

 Parent elements: Fonts

Child elements: None

<Fonts> element

Contains the FontEntry elements listing the fonts used in the ConceptDraw document.

Syntax

 <Fonts>
</Fonts>

Attributes

 None.

Element information

 Parent elements: IndexDecoder

Child elements: FontEntry (optional)

<Geom> element

Contains elements that specify the coordinates of the vertices for the lines and arcs that make up the shape. If the shape has more than one path, there is a Geom element for each path.

Syntax

 <Geom
[IX = "intval"]>
</Geom>

Attributes

 IX
Optional int. The one-based index of the element within its parent element. If the index is not specified, it is obtained by incrementing the maximum index of the existing Geom elements in the current Shape. If the given index already exists, all the child elements will modify the existing geometry.

Element information

 Parent elements: Geometries

Child elements: Visible (optional), Filled (optional), Start (optional), LineTo (optional), ArcTo (optional), EllipseTo (optional),
SplineStart (optional), SplineKnot (optional)

<Geometries> element

Contains elements that define a geometry in parent Shape.

Syntax

 <Geometries>
</Geometries>

Attributes

 None.

Element information

 Parent elements: Shape

Child elements: Geom (optional)

<GlueSettings> element

Determines whether the mode of gluing shapes to the guides is enabled.

Value | Description
0 1 | Glue is disabled. Glue is enabled.

Syntax

 <GlueSettings>
intval
</GlueSettings>

Attributes

 None.

Element information

 Parent elements: DocumentSettings

Child elements: None

Remarks
At present, ConceptDraw only supports gluing the shapes to the service objects like guide lines.

<GPinX> element

Specifies the x-coordinate of the shape's or service object's pin (center of rotation) in relation to the origin of its parent.

Syntax

 <GPinX
[Unit = "unitval"]
[F = "formula"]
[Err = "error"]>
doubleval
</GPinX>

Attributes

Unit
Optional string. Represents the unit of measure in which the value is specified. It can take one of the values from the "Abbreviation for use" column from the table of the supported units of measure. The default value is the ConceptDraw internal measurement unit: 1 = 0.1 mm.
F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 8 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Transform , ServObj

Child elements: None

<GPinY> element

Specifies the y-coordinate of the shape's or service object's pin (center of rotation) in relation to the origin of its parent.

Syntax

 <GPinY
[Unit = "unitval"]
[F = "formula"]
[Err = "error"]>
doubleval
</GPinY>

Attributes

Unit
Optional string. Represents the unit of measure in which the value is specified. It can take one of the values from the "Abbreviation for use" column from the table of the supported units of measure. The default value is the ConceptDraw internal measurement unit: 1 = 0.1 mm.
F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 8 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Transform , ServObj

Child elements: None

<HAlign> element

Specifies the horizontal alignment of text in the shape's text block.

Value | Description
0 1 2 3 4 | Left Center Right Justify Force justify

Syntax

 <HAlign
[F = "formula"]
[Err = "error"]>
intval
</HAlign>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 1 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Paragraph

Child elements: None

Remarks
The 3="Justify" and 4="Force justify" values are supported starting from version 2.0.
"Justify" adjusts the space between words in every line except the last line of the paragraph. This aligns both the left and right sides of the text with the margins.
"Force justify" justifies every line in the paragraph, including the last.

<Height> element

Contains the height of the associated shape in drawing units.

Syntax

 <Height
[Unit = "unitval"]
[F = "formula"]
[Err = "error"]>
doubleval
</Height>

Attributes

Unit
Optional string. Represents the unit of measure in which the value is specified. It can take one of the values from the "Abbreviation for use" column from the table of the supported units of measure. The default value is the ConceptDraw internal measurement unit: 1 = 0.1 mm.
F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 8 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Transform

Child elements: None

<Hyperlink> element

Contains an index of the shape's hyperlink in the Hyperlinks list of the document.

Syntax

 <Hyperlink
[F = "formula"]
[Err = "error"]>
intval
</Hyperlink>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 8 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Shape

Child elements: None

<HyperlinkEntry> element

Contains a string with the target address the hyperlink points to, and the attributes for the hyperlink type.

Syntax

 <HyperlinkEntry
 [IX = "intval"]
 [LinkType = "enumval"]
 [PageID = "intval"]
 [ObjID = "intval"]
 [LocalPath = "boolval"]>
strval
</HyperlinkEntry>

Attributes

 IX
Optional int. The one-based index of the element within its parent element. If the index is not specified, it is obtained by incrementing the index of the previous HyperlinkEntry.
LinkType
Optional enumval. The type of hyperlink, taking the following possible values: None, LinkToFile, LinkToURL, LinkToPageObj. The default value is None.
PageID
Optional int. Page ID of the target page. Valid only if LinkType = LinkToPageObj.
ObjID
Optional int. Object ID of the target object. Valid only for LinkType = LinkToPageObj. Supported in the XML for ConceptDraw starting from version 2.0.
LocalPath
Optional bool. Shows whether the local path to the target resourse should be used after the full path given in strval. Valid only for LinkType = LinkToFile.

Element information

 Parent elements: HyperLinks

Child elements: None

<HyperLinks> element

Contains the HyperlinkEntry elements listing the hyperlinks used in the ConceptDraw document.

Syntax

 <HyperLinks>
</HyperLinks>

Attributes

 None.

Element information

 Parent elements: IndexDecoder

Child elements: HyperlinkEntry (optional)

<IndexDecoder> element

Contains the elements describing the indexed ConceptDraw objects such as ColorPalette, Fonts, HyperLinks.

Syntax

 <IndexDecoder>
</IndexDecoder>

Attributes

 None.

Element information

 Parent elements: ConceptDrawDocument

Child elements: ColorPalette (optional), Fonts (optional), HyperLinks (optional)

<Justification> element

Determines the position of the document on the print pages.
The possible values are described in thre following table:

Value | Description
LeftTop LeftCentre LeftBottom CentreTop Centre CentreBottom RightTop RightCentre RightBottom | Left and top justification. Left and centre justification. Left and bottom justification. Centre and top justification. Centre justification. Centre and bottom justification. Right and top justification. Right and centre justification. Right and bottom justification.

Syntax

 <Justification>
enumval
</Justification>

Attributes

 None.

Element information

 Parent elements: PrintSetup

Child elements:

Remarks
XML for ConceptDraw v1.x supports only 3 possible values: "LeftTop", "Centre", "RightBottom". All the rest are supported starting from version 2.0.

<Language> element

Specifies the language of the text.

Syntax

 <Language
[F = "formula"]
[Err = "error"]>
byteval
</Language>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 8 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Character

Child elements: None

<Layer> element

Contains elements that define a single layer and its properties.

Syntax

 <Layer
[IX = "intval"]
[Active = "boolval"]
[Visible = "boolval"]
[Locked = "boolval"]
[Print = "boolval"]
[Colored = "boolval"]/>

Attributes

 IX
Optional int. The one-based index of the element within its parent element. If the index is not specified, it is obtained by incrementing the index of the previous Layer. If the index specified is that of some layer already defined, this layed gets redefined.
Active
Optional bool.
Visible
Optional bool.
Locked
Optional bool.
Print
Optional bool. Supported in the XML for ConceptDraw starting from version 2.0.
Colored
Optional bool.

Element information

 Parent elements: Layers

Child elements: LayerName (optional), Color (optional)

Remarks
The 1.x version supports up to 9 layers. Starting from version 2.0, any number of layers is supported.

<LayerInd> element

Specifies the index of the layer to which the given Shape or ServObj is assigned.

Syntax

 <LayerInd
[F = "formula"]
[Err = "error"]>
intval
</LayerInd>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 8 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Shape , ServObj

Child elements: None

<LayerName> element

Contains a string specifying the layer name.

Syntax

 <LayerName>
strval
</LayerName>

Attributes

 None.

Element information

 Parent elements: Layer

Child elements: None

<Layers> element

Contains the Layer elements listing the layers of the ConceptDraw document.

Syntax

 <Layers>
</Layers>

Attributes

 None.

Element information

 Parent elements: ConceptDrawDocument

Child elements: Layer (optional)

Remarks
The 1.x version supports up to 9 layers. Starting from version 2.0, any number of layers is supported.

<LeftInd> element

Specifies the distance all lines of text in a paragraph are indented from the left margin of the text block. This value is independent of the scale of the drawing. If the drawing is scaled, the left indent remains the same.

Syntax

 <LeftInd
[F = "formula"]
[Err = "error"]>
floatval
</LeftInd>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 8 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Paragraph

Child elements: None

<LeftMargin> element

Specifies the distance between the left border of the text block and the text it contains.

Syntax

 <LeftMargin
[F = "formula"]
[Err = "error"]>
floatval
</LeftMargin>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 8 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: TextBlock

Child elements: None

<LineBegin> element

Determines the type of arrowhead used for the beginning of the line.

Syntax

 <LineBegin
[F = "formula"]
[Err = "error"]>
intval
</LineBegin>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 8 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: LineProperties, DefaultSettings

Child elements: None

Remarks
ConceptDraw supports up to 60 types of arrowheads, so the element may take the values from 0 to 60. The "0" value indicates the absence of arrowhead at the beginning of the line.

<LineColor>, <Color>, <PatColor>, <TextBkgnd> elements

Specify the colors of line, fill, fill pattern, layer, etc.
The color can be identified according to different color schemes.
The color can be determined by its index in the document color palette, or specified directly by its components. For detemining the color, two color chemes are supported: RGB and CMYK.
Thus, colorval presents a string taking the following values:

'RGB(red,green,blue)'
'RGBA(red,green,blue,alpha)'
'CMYK(cyan,magenta,yellow,black)'
'CMYKA(cyan,magenta,yellow,black,alpha)'
'colorIndex'
'colorIndex,alpha'

here red,green,blue are integers within the (0 .. 255) range, determining the color components for the RGB scheme;
cyan,magenta,yellow,black - are integers within the (0 .. 100) range, determining the color components for the CMYK scheme;
colorIndex is integer for the index of this color in the document color palette;
alpha is integer within (0 .. 1), setting the transparence, with 1 standing for transparent, and 0 for oblique.

Syntax

 <Color
[F = "formula"]
[Err = "error"]>
colorval
</Color>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally. If the attribute is not present, the element's formula is a simple constant, for example, <element> 'RGB(255,255,255)' </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: LinePen, Fill , Shadow , Character, Layer

Child elements: None

<LineEnd> element

Determines the type of arrowhead used for the ending of the line.

Syntax

 <LineEnd
[F = "formula"]
[Err = "error"]>
intval
</LineEnd>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 8 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: LineProperties, DefaultSettings, Style

Child elements: None

Remarks
ConceptDraw supports up to 60 types of arrowheads, so the element may take the values from 0 to 60. The "0" value indicates the absence of arrowhead at the ending of the line.

<LineEndsSize> element

Determines the size of the arrowheads, taking one of the following values:

Value | Description
0 1 2 3 4 | Tiny. Small. Medium. Large. Huge.

Syntax

 <LineEndsSize
[F = "formula"]
[Err = "error"]>
intval
</LineEndsSize>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 8 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: LineProperties, DefaultSettings

Child elements: None

<LinePattern> element

Specifies the number of the pattern used when drawing the line.

Syntax

 <LinePattern
[F = "formula"]
[Err = "error"]>
intval
</LinePattern>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 8 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: LinePen

Child elements: None

Remarks
ConceptDraw supports up to 16 line patterns, so this element may take the values from 0 to 16. The "0" value corresponds to the transparent pattern, so the line drawn with this pattern is completely invisible.

<LineWeight> element

Specifies the line thickness.

Syntax

 <LineWeight
[F = "formula"]
[Err = "error"]>
intval
</LineWeight>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 8 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: LinePen

Child elements: None

<LinePen> element

Contains the property elements for the pen with which the line is drawn.

Syntax

 <LinePen
</LinePen>

Attributes

 None.

Element information

 Parent elements: LineProperties, DefaultSettings, Style

Child elements: LinePattern (optional), LineWeight (optional), LineColor (optional)

<LineProperties> element

Contains the property elements describing the line.

Syntax

 <LineProperties
</LineProperties>

Attributes

 None.

Element information

 Parent elements: Shape

Child elements: LinePen (optional), LineBegin (optional), LineEnd (optional), LineEndsSize (optional)

<LineTo> element

Contains x- and y-coordinates of the ending vertex of a straight line segment. These coordinates are contained in the X and Y elements, respectively.

Syntax

 <LineTo
[IX = "intval"]>
</LineTo>

Attributes

 IX
Optional int. The one-based index of the element within its parent element. If the index is not specified, it is obtained by incrementing the maximum index of the existing segments in the current geometry. If the given index already exists, all the child elements will modify the existing segment.

Element information

 Parent elements: Geom

Child elements: X (optional), Y (optional)

<LockAspect> element

Specifies whether the aspect ratio of the shape is locked. If locked, the shape can only be sized proportionally; it cannot be sized in a single dimension.

Value | Description
0 1 | Aspect ratio is not locked. Aspect ratio is locked.

Syntax

 <LockAspect
[F = "formula"]
[Err = "error"]>
boolval
</LockAspect>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 1 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Protection

Child elements: None

<LockBegin> element

Specifies whether the begin point of a 1-D shape is locked to a specific location.

Value | Description
0 1 | Begin point is not locked. Begin point is locked.

Syntax

 <LockBegin
[F = "formula"]
[Err = "error"]>
boolval
</LockBegin>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 1 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Protection

Child elements: None

<LockCalcWH> element

Specifies whether a shape's selection rectangle is locked so it cannot be recalculated when a vertex is edited or an element type is changed in the Geom element.

Value | Description
0 1 | Width and height can be recalculated. Width and height cannot be recalculated.

Syntax

 <LockCalcWH

[F = "formula"]
[Err = "error"]>
boolval
</LockCalcWH>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 1 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Protection

Child elements: None

<LockDelete> element

Specifies whether a shape is locked against being deleted.

Value | Description
0 1 | Shape can be deleted. Shape cannot be deleted.

Syntax

 <LockDelete
[F = "formula"]
[Err = "error"]>
boolval
</LockDelete>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 1 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Protection

Child elements: None

<LockEnd> element

Specifies whether the end point of a 1-D shape is locked to a specific location.

Value | Description
0 1 | End point is not locked. End point is locked.

Syntax

 <LockEnd
[F = "formula"]
[Err = "error"]>
boolval
</LockEnd>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 1 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Protection

Child elements: None

<LockHeight> element

Specifies whether the height of the shape is locked. If locked, its height remains unchanged when the shape is resized.

Value | Description
0 1 | Height is not locked. Height is locked.

Syntax

 <LockHeight
[F = "formula"]
[Err = "error"]>
boolval
</LockHeight>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 1 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Protection

Child elements: None

<LockFlipX> element

Specifies whether the horizontal flip of the shape is locked.

Value | Description
0 1 | The horizontal flip is not locked. The horizontal flip is locked.

Syntax

 <LockFlipX
[F = "formula"]
[Err = "error"]>
boolval
</LockFlipX>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example,

<element> 1 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Protection

Child elements: None

<LockFlipY> element

Specifies whether the vertical flip of the shape is locked.

Value | Description
0 1 | The vertical flip is not locked. The vertical flip is locked.

Syntax

 <LockFlipY
[F = "formula"]
[Err = "error"]>
boolval
</LockFlipY>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 1 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Protection

Child elements: None

<LockMoveX> element

Specifies whether the horizontal position of the shape is locked so that it cannot be moved horizontally.

Value | Description
0 1 | Horizontal position is not locked. Horizontal position is locked.

Syntax

 <LockMoveX
[F = "formula"]
[Err = "error"]>
boolval
</LockMoveX>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 1 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Protection

Child elements: None

<LockMoveY> element

Specifies whether the vertical position of the shape is locked so that it cannot be moved vertically.

Value | Description
0 1 | Vertical position is not locked. Vertical position is locked.

Syntax

 <LockMoveY
[F = "formula"]
[Err = "error"]>
boolval
</LockMoveY>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 1 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Protection

Child elements: None

<LockRotate> element

Specifies whether the shape is locked against being rotated with the Rotation tool or the Rotate Left or Rotate Right commands in ConceptDraw.

Value | Description
0 1 | Shape can be rotated. Shape cannot be rotated.

Syntax

 <LockRotate
[F = "formula"]
[Err = "error"]>
boolval
</LockRotate>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 1 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Protection

Child elements: None

<LockVertex> element

Specifies whether the vertices of a shape are locked so that they cannot be edited with any tools on the toolbar.

Value | Description
0 1 | Vertices can be edited. Vertices cannot be edited.

Syntax

 <LockVertex
[F = "formula"]
[Err = "error"]>
boolval
</LockVertex>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 1 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Protection

Child elements: None

<LockWidth> element

Specifies whether the width of the shape is locked so that it remains unchanged when the shape is resized.

Value | Description
0 1 | Width is not locked. Width is locked.

Syntax

 <LockWidth
[F = "formula"]
[Err = "error"]>
boolval
</LockWidth>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 1 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Protection

Child elements: None

<LocPinX> element

Specifies the x-coordinate of the shape's pin (center of rotation) in relation to the origin of the shape.

Syntax

 <LocPinX
[Unit = "unitval"]
[F = "formula"]
[Err = "error"]>
doubleval
</LocPinX>

Attributes

Unit
Optional string. Represents the unit of measure in which the value is specified. It can take one of the values from the "Abbreviation for use" column from the table of the supported units of measure. The default value is the ConceptDraw internal measurement unit: 1 = 0.1 mm.
 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 8 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Transform

Child elements: None

<LocPinY> element

Specifies the y-coordinate of the shape's pin (center of rotation) in relation to the origin of the shape.

Syntax

 <LocPinY
[Unit = "unitval"]
[F = "formula"]
[Err = "error"]>
doubleval
</LocPinY>

Attributes

Unit
Optional string. Represents the unit of measure in which the value is specified. It can take one of the values from the "Abbreviation for use" column from the table of the supported units of measure. The default value is the ConceptDraw internal measurement unit: 1 = 0.1 mm.
 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 8 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Transform

Child elements: None

<Menu> element

Specifies the name of the command that appears on the shortcut menu for a shape.

Syntax

 <Menu
[F = "formula"]
[Err = "error"]>
strval
</Menu>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 8 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Act

Child elements: None

<Misc> element

Contains elements specifying information on the behaviour, highlighting and visibility of the shape.

Syntax

 <Misc>
</Misc>

Attributes

 None.

Element information

 Parent elements: Shape

Child elements: ShowShapeHandles (optional), ShowControlHandles (optional), ShowAlignBox (optional),
ShowText (optional), NonPrinting (optional), ResizeBehaviour (optional)

<NonPrinting> element

Specifies whether the selected shape can be printed.

Value | Description
0 1 | Printing is enabled. Printing is disabled, but the shape is displayed in the drawing window.

Syntax

 <NonPrinting
[F = "formula"]
[Err = "error"]>
boolval
</NonPrinting>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 1 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Misc

Child elements: None

<OleData> element

Contains a MIME (Multipurpose Internet Mail Extensions) encoded BLOB of OLE data.
In this case, the Base64 encoding is used.

Syntax

 <OleData
[ObjectType = "intval"]
[ShowAsIcon = "boolval"]>
blob
</OleData>

Attributes

 ObjectType
Optional int. The ObjectType attribute is an integer value that may be a sum of the following values.

Value | Description
256 512 1024 16384 32768 | Linked object Embedded object Control OLE2 Named OLE2 object

ShowAsIcon
 Optional boolean. This attribute is only meaningful if the ole data is an OLE2 embedded object

Value | Description
0 1 | Do not show embedded data as an icon. Show embedded data as an icon.

Element information

 Parent elements: Shape

Child elements: None

<Page> element

Contains elements that define a page in the document.

Syntax

 <Page
ID = "intval"
[Name = "name"]
[Background = "boolval"]
[BackPage = "intval"]
[ViewScale = "floatval"]
[ViewCenterX = "floatval"]
[ViewCenterY = "floatval"]>
</Page>

Attributes

 ID
Required int. The unique ID of the element within its parent element.
Name
 Optional string. The name of the element.
Background
 Optional boolean. A flag indicating if the page is a background page.
BackPage
 Optional int. The ID of this page's background page.
ViewScale
Optional float. The default magnification factor to use when a new view (window) of the page is opened. For example, 1 = 100%; 1.5 = 150%, and so on.
ViewCenterX
Optional float. ViewCenterX and ViewCenterY specify a center point on a page that a new view (window) assumes when it is opened initially.
ViewCenterY
Optional Float. ViewCenterX and ViewCenterY specify a center point on a page that a new view (window) assumes when it is opened initially.

Element information

 Parent elements: Pages

Child elements: Shapes (optional), Services (optional)

Remarks
The order of Page elements within the Pages element determines the order in which the pages are displayed in the ConceptDraw user interface.

<PageBottomMargin> element

Specifies the bottom margin (in internal units) when printing the pages of the document.

Syntax

 <PageBottomMargin>
floatval
</PageBottomMargin>

Attributes

 None.

Element information

 Parent elements: PrintSetup

Child elements:

<PageLeftMargin> element

Specifies the left margin (in internal units) used when printing the pages of the document.

Syntax

 <PageLeftMargin>
floatval
</PageLeftMargin>

Attributes

 None.

Element information

 Parent elements: PrintSetup

Child elements:

<PageRightMargin> element

Specifies the right margin (in internal units) used when printing the pages of the document.

Syntax

 <PageRightMargin>
floatval
</PageRightMargin>

Attributes

 None.

Element information

 Parent elements: PrintSetup

Child elements: None

<Pages> element

Contains the Page elements for the document.

Syntax

 <Pages>
</Pages>

Attributes

Element information

 Parent elements: ConceptDrawDocument

Child elements: Page (optional)

Remarks
The order of Page elements within the Pages element determines the order in which the pages are displayed in the ConceptDraw user interface.

<PageSettings> element

Contains the elements describing the parameters of document pages.

Syntax

 <PageSettings>
</PageSettings>

Attributes

 None.

Element information

 Parent elements: DocumentProperties

Child elements: PageSizeType (optional), PageWidth (optional), PageHeight (optional)

<PageSizeType> element

Determines the type of document page size and the page orientation.

Syntax

 <PageSizeType
[Type = "enumval"]
[PredefSize = "enumval"]
[Orientation = "boolval"] />

Attributes

 Type
Optional enum. Determines the type of the page size, and takes one of the following values: SameAsPrinter, FitToDrawing, Standard, MetricISO, Custom.
PredefSize
Optional enum. Determines the preset page size. It is valid only for Type = "Standard" or Type = "MetricISO". In case Type = "Standard", it takes one of the following values: Letter, Folio, Legal, Tabloid . And for Type = "MetricISO", the possible values are: A5, A4, A3, A2, A1, A0.
Orientation
Optional bool. Determines the orientation of the document pages. The TRUE value corresponds to the "Portrait" orientation, and FALSE to the "Landscape".

Element information

 Parent elements: PageSettings

Child elements: None

<PageTopMargin> element

Specifies the top margin (in internal units) used when printing the pages of the document.

Syntax

 <PageTopMargin>
floatval
</PageTopMargin>

Attributes

 None.

Element information

 Parent elements: PrintSetup

Child elements:

<PageWidth> element

Determines the width of the document pages. It contains both the numeric value and the original string determining this value.

Syntax

 <PageWidth
[Str = "strval"]>
doubleval
</PageWidth>

Attributes

 Str
Optional string. The original string determining the numeric value for the width. The string normally contains a number and some measurement unit, e.g. "8.5 in". It is supported in XML for ConceptDraw starting from version 2.0.

Element information

 Parent elements: PageSettings

Child elements: None

Remarks
The numeric value is specified in the ConceptDraw internal measurement unit: 1 = 0.1 mm (millimeter).
Example: The width set as "8.5 in" will be coded as "2159".

<PageHeight> element

Determines the height of the document pages. It contains both the numeric value and the original string determining this value.

Syntax

 <PageHeight
[Str = "strval"]>
doubleval
</PageHeight>

Attributes

 Str
Optional string. The original string determining the numeric value for the height. The string normally contains a number and some measurement unit, e.g. "11 in". It is supported in XML for ConceptDraw starting from version 2.0.

Element information

 Parent elements: PageSettings

Child elements: None

Remarks
The numeric value is specified in the ConceptDraw internal measurement unit: 1 = 0.1 mm (millimeter).
Example: The width set as "11 in" will be coded as "2794".

<PaperOrientation> element

Shows the paper orientation in printing. Takes the following values:

Value | Description
0 1 | Landscape orientation. Portrait orientation.

Syntax

 <PaperOrientation>
boolval
</PaperOrientation>

Attributes

 None.

Element information

 Parent elements: PrintSetup

Child elements: None

<PaperSize> element

Specifies the paper size of a document. The following table lists common settings.

Value

 Description

UNKNOWN

LETTER

LEGAL

A4

CSHEET

DSHEET

ESHEET

LETTERSMALL

TABLOID

LEDGER

STATEMENT

EXECUTIVE

A3

A4SMALL

A5

B4

B5

FOLIO

QUARTO

10X14

11X17

NOTE

ENV_9

ENV_10

ENV_11

ENV_12

ENV_14

ENV_DL

ENV_C5

ENV_C3

ENV_C4

ENV_C6

ENV_C65

ENV_B4

ENV_B5

ENV_B6

ENV_ITALY

ENV_MONARCH

ENV_PERSONAL

FANFOLD_US

FANFOLD_STD_GERMAN

FANFOLD_LGL_GERMAN

Letter, 8 1/2- by 11-inches

Legal, 8 1/2- by 14-inches

A4 Sheet, 210- by 297-millimeters

C Sheet, 17- by 22-inches

D Sheet, 22- by 34-inches

E Sheet, 34- by 44-inches

Letter Small, 8 1/2- by 11-inches

Tabloid, 11- by 17-inches

Ledger, 17- by 11-inches

Statement, 5 1/2- by 8 1/2-inches

Executive, 7 1/4- by 10 1/2-inches

A3 sheet, 297- by 420-millimeters

A4 small sheet, 210- by 297-millimeters

A5 sheet, 148- by 210-millimeters

B4 sheet, 250- by 354-millimeters

B5 sheet, 182- by 257-millimeter paper

Folio, 8 1/2- by 13-inch paper

Quarto, 215- by 275-millimeter paper

10- by 14-inch sheet

11- by 17-inch sheet

Note, 8 1/2- by 11-inches

#9 Envelope, 3 7/8- by 8 7/8-inches

#10 Envelope, 4 1/8- by 9 1/2-inches

#11 Envelope, 4 1/2- by 10 3/8-inches

#12 Envelope, 4 3/4- by 11-inches

#14 Envelope, 5- by 11 1/2-inches

DL Envelope, 110- by 220-millimeters

C5 Envelope, 162- by 229-millimeters

C3 Envelope, 324- by 458-millimeters

C4 Envelope, 229- by 324-millimeters

C6 Envelope, 114- by 162-millimeters

C65 Envelope, 114- by 229-millimeters

B4 Envelope, 250- by 353-millimeters

B5 Envelope, 176- by 250-millimeters

B6 Envelope, 176- by 125-millimeters

Italy Envelope, 110- by 230-millimeters

Monarch Envelope, 3 7/8- by 7 1/2-inches

6 3/4 Envelope, 3 5/8- by 6 1/2-inches

US Std Fanfold, 14 7/8- by 11-inches

German Std Fanfold, 8 1/2- by 12-inches

German Legal Fanfold, 8 1/2- by 13-inches

Syntax

 <PaperSize>
enumval
</PaperSize>

Attributes

 None.

Element information

 Parent elements: PrintSetup

Child elements: None

<PaperHeight> element

Specifies the height (in internal units) of a document's printed page. This element overrides the size specified by the PaperSize element.

Syntax

 <PaperHeight>
floatval
</PaperHeight>

Attributes

 None.

Element information

 Parent elements: PrintSetup

Child elements: None

<PaperWidth> element

Specifies the width (in internal units) of a document's printed page. This element overrides the size specified by the PaperSize element.

Syntax

 <PaperWidth>
floatval
</PaperWidth>

Attributes

 None.

Element information

 Parent elements: PrintSetup

Child elements: None

<Paragraph> element

Contains the paragraph formatting elements for the shape's text, such as indents, line spacing, bullets, and horizontal alignment of paragraphs.

Syntax

 <Paragraph
[IX = "intval"]
[CharCount = "intval"]
</Paragraph>

Attributes

IX
 Optional int. The zero-based index of the element within its parent element.
 CharCount
Optional int.The number of characters in the given paragraph. The default value is 0.

Element information

 Parent elements: Text , DefaultSettings

Child elements: HAlign (optional), LeftInd (optional), RightInd (optional), FirstInd (optional)

<Pattern> element

Specifies the number of the fill pattern used for the shape or the shape's drop shadow.

Syntax

 <Pattern
[F = "formula"]
[Err = "error"]>
intval
</Pattern>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 8 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Fill , Shadow

Child elements: None

Remarks
ConceptDraw supports 53 fill patterns for shapes and 38 fill patterns for shadows. So this element may take the values from 0 to 53 for shapes and from 0 to 38 for shadows. The "0" value corresponds to the transparent fill.

<PICT> element

Contains a MIME (Multipurpose Internet Mail Extensions) encoded BLOB of Macintosh PICT data.
In this case, the Base64 encoding is used.

Syntax

 <PICT>
blob
</PICT>

Attributes

 None.

Element information

 Parent elements: ResData

Child elements: None

<Picture> element

Contains a reference to the data resource in the Resources collection.

Syntax

 <Picture
ResID = "intval"/>

Attributes

 ResID
Required int. Specifies the index identifying the ResData element in the Resources collection.

Element information

 Parent elements: Shape

Child elements: None

<PlacementMethod> element

Determines how the document is tiled into print pages if one document page takes several sheets of paper in printing.
Starting from version 2.0, this element also takes effect if several pages of the document are printed on one print page.
The element may take the following values:

Value | Description
LeftToRight TopToDown | Tiling from left to right is preferred. Tiling from top down is preferred.

Syntax

 <PlacementMethod
 [UsePlacing = "boolval"]>
enumval
</PlacementMethod>

Attributes

 UsePlacing
 Optional bool. Supported starting from version 2.0. If several document pages can be placed on one print page, this attribute shows whether the document pages should be tiled on the print page. For "TRUE" or "1", the tiling will be applied; and for "FALSE" or "0", each page of the document will be printed on a separate print page.
This attribute is ignored if a print page cannot contain more than one document page.

Element information

 Parent elements: PrintSetup

Child elements: None

<PrintSetup> element

Contains elements that specify printing settings.

Syntax

 <PrintSetup>
</PrintSetup>

Attributes

 None.

Element information

 Parent elements: ConceptDrawDocument

Child elements: PrintSize (optional), Justification (optional), PlacementMethod (optional), PaperOrientation (optional), PaperSize (optional), PaperWidth (optional), PaperHeight (optional), PageTopMargin (optional), PageBottomMargin (optional), PageLeftMargin (optional), PageRightMargin (optional)

<PrintSize> element

Determines the size at which the document should be printed.

Syntax

 <PrintSize
 [Type = "enumval"]
[Zoom = "floatval"]
[FitToPages = "intval"]/>

Attributes

 Type
Optional enum. The Size type, taking one of the following values: Actual, Zoom, FitToPages.
Zoom
Optional float. Determines the zoom level at which the document should be printed. It is valid in case Type = "Zoom". Supported in the XML for ConceptDraw starting from version 2.0.
FitToPages
Optional int. Determines the number of pages to which every page of the document should be fit in printing. Valid for Type = "FitToPages".

Element information

 Parent elements: PrintSetup

Child elements: None

<Prompt> element

Contains varying prompt information, based on the element in which it is contained.

When contained in a Act element, specifies a descriptive prompt or comment for the Act element.

Syntax

 <Prompt
[F = "formula"]
[Err = "error"]>
strval
</Prompt>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> "prompt" </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Act , CustomProp , Master

Child elements: None

Remarks

<Protection> element

Includes elements describing the protection of shape parameters against changing.

Syntax

 <Protection
</Protection>

Attributes

 None.

Element information

 Parent elements: Shape

Child elements: LockWidth (optional), LockHeight (optional), LockMoveX (optional), LockMoveY (optional),
LockBegin (optional), LockEnd (optional), LockVertex (optional), LockFlipX (optional),
LockFlipY (optional), LockRotate (optional), LockDelete (optional), LockAspect (optional),
LockCalcWH (optional)

<Raster>, <PreviewPicture>, <Icon> elements

Contains a MIME (Multipurpose Internet Mail Extensions) encoded BLOB of Bitmap data.
In this case, the Base64 encoding is used.

Syntax

 <RasterPicture
[Format = "enumval"]
[Width = "intval"]
 [Height = "intval"]
 [RowWidth = "intval"]>
blob
</RasterPicture>

Attributes

Format
Optional enumeration. The format for stroing the raster data. The possible values are: TrueColorRow, DIB, BMP, JPEG, GIF, TIFF, PNG, TGA . The default value is TrueColorRow.
 Width
Optional int. The width of the Bitmap. If Format=TrueColorRow, then this attribute is required; in other cases, it is ignored.
Height
Optional int. The height of the Bitmap. If Format=TrueColorRow, then this attribute is required; in other cases, it is ignored.
RowWidth
Optional int. The width of the Bitmap's raster row. By default, it equals to Width. If the Format differs from TrueColorRow, this attribute is ignored.

Element information

 Parent elements: ResData , DocumentProperties , Master

Child elements: None

<ResData> element

Contains information on the resource of such shapes as RasterPicture, VectorPictureMF, VectorPicturePICT or VectorPicture.
Starting from version 2.0, it also contains information on the origin of the resource.

Syntax

 <ResData
[ID = "intval"]
[Type = "enumval"]
[ParentName = "string"]
[ParentTime = "string"]
[ParentLength = "intval"]
[ParentResID = "intval"]>
</ResData>

Attributes

 ID
Optional int. Defines the unique index of the resource within its parent element - Resources.
Type
Optional enumval. Specifies the type of the resource, taking one of the following values: RasterPicture, VectorPictureMF, VectorPicturePICT or VectorPicture.
ParentName
Optional string. Name of the parent file from which the given resource was inserted/obtained. Supported starting from version 2.0.
ParentTime
Optional string. The last modified time for the parent file from which the given resource was inserted/obtained. Supported starting from version 2.0.
ParentLength
Optional int. The size of the parent file from which the given resource was inserted/obtained. Supported starting from version 2.0.
ParentResID
Optional int. The index identifying the resource in the document or library from which the given resource was obtained. Supported starting from version 2.0.

Element information

 Parent elements: Resources

Child elements: Raster (optional), EnhMetaFile (optional), PICT (optional), VectorObj(optional)

Remarks
The VectorPicture type is supported in the XML for ConceptDraw starting from version 2.0.
The VectorObj elements are also supported starting from version 2.0.

<ResizeBehaviour> element

Determines the behaviour of an object within a group, when the group is resized. It takes one of the following values:

Value | Description
0 1 2 | Scale width group. Reposition only. Use group's setting.

Syntax

 <ResizeBehaviour
[F = "formula"]
[Err = "error"]>
intval
</ResizeBehaviour>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 1 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Misc

Child elements: None

<Resources> element

Contains the elements describing the resources for shapes of such types as RasterPicture, VectorPictureMF, VectorPicturePICT or VectorPicture.

Syntax

 <Resources>
</Resources>

Attributes

 None.

Element information

 Parent elements: ConceptDrawDocument

Child elements: ResData (optional)

Remarks
The VectorPicture type is supported in the XML for ConceptDraw starting from version 2.0.

<RightInd> element

Specifies the distance all lines of text in a paragraph are indented from the right margin of the text block. This value is independent of the scale of the drawing. If the drawing is scaled, the right indent remains the same.

Syntax

 <RightInd
[F = "formula"]
[Err = "error"]>
floatval
</RightInd>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 8 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Paragraph

Child elements: None

<RightMargin> element

Specifies the distance between the right border of the text block and the text it contains.

Syntax

 <RightMargin
[F = "formula"]
[Err = "error"]>
floatval
</RightMargin>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 8 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: TextBlock

Child elements: None

<Scale> element

Contains the scale of the document. It holds both the numeric value and the original strings determining this value.

Syntax

 <Scale
[Type = "enumval"]
[Custom = "strval"]>
doubleval
</Scale>

Attributes

 Type
Optional enum. Determines the scale type. It can take one of the following values:

Value | Description
NoScale Metric CivilEng MechEng Architect Custom | No scale. Metric scale. Civil engineering scale. Mechanical engineering scale. Architectural scale. Custom scale

Custom
Optional string. This string determines the custom scale. It is valid only in case Type = "Custom".

Element information

 Parent elements: DocumentSettings

Child elements: None

<Services> element

Contains a collection of ServObj elements.

Syntax

 <Services>
</Services>

Attributes

 None.

Element information

 Parent elements: Page, Shape

Child elements: ServObj (optional)

<ServObj> element

Contains elements that define a service object in a Page or group shape element.

Syntax

 <ServObj
[ID = "intval"]
[Name = "name"]
[SubID = "intval"]
[Type = "enumval"]>
</ServObj>

Attributes

 ID
Optional int. The unique ID of the element within its Document.
Name
Optional string. The name of the element.
SubID
Optional int. The unique ID of the element within its parent element.
Type
Optional enumeration. The type of a service object. In the current version of the XML for ConceptDraw it may take only one value: Guide.

Element information

 Parent elements: Services

Child elements: Angle (optional), GPinX (optional), GPinY (optional) , Desc (optional), LayerInd (optional)

<ShadowOffset> element

Determines the offset of the shadows of shapes in the document.

Syntax

 <ShadowOffset
[X="doubleval"]
[Y="doubleval"] />

Attributes

 X
Optional double. The horizontal offset of the shadows. Expressed in the ConceptDraw internal measurement units: 1 = 0.1 mm.
Y
Optional double. The vertical offset of the shadows. Expressed in the ConceptDraw internal measurement units: 1 = 0.1 mm.

Element information

 Parent elements: DocumentSettings

Child elements: None

<Shape> element

Contains elements that define a shape in a Page, Master or group shape element.

Syntax

 <Shape
[ID = "intval"]
[Name = "name"]
[SubID = "intval"]
[Type = "enumval"]
[MasterLibrary = "libname"]
[MasterName = "name"]
[MasterID = "intval"]>
</Shape>

Attributes

 ID
Optional int. The unique ID of the element within its Library or Document. If the ID is not specified, it is generated automatically to be unique within the document.
Name
Optional string. The name of the element.
SubID
Optional int. The unique ID of the element within its parent element. If the SubID is not specified, it is generated automatically to be unique within the parent document.
Type
Optional enumeration. The type of a shape. It may be one of the following values: Group, Shape, Connector, SmartConnector, OleObj, VectorPicture, RasterPicture, VectorPictureMF, VectorPicturePICT.
MasterLibrary
The name of the library form which the Master is taken for building this Shape.
This may be either a file name, or the name of a built-in library.
MasterName
The name of Master used for building the Shape. The Master is taken from the MasterLibrary.
MasterID
Unique ID of the Master object according to which the Shape is built. The Master is taken from the MasterLibrary.

Element information

 Parent elements: Shapes, Master

Child elements: Transform (optional), EndPoints (optional), ConnectInfo (optional), Misc (optional), LayerInd (optional), Hyperlink (optional), DblClick (optional), Geometries (optional), LineProperties (optional), FillFormat (optional), Protection (optional), Text (optional), Shapes (optional), OleData (optioanl), Actions (optional), Services (optional), Controls (optional), Variables (optional), Connections (optional), Desc (optional), Picture (optional)

Remarks
1) If a shape with the given ID already exists, all the child elements listed above are used for modifying the corresponding properties of the existing Shape.
2) The VectorPicture type is supported in the XML for ConceptDraw starting from version 2.0.

<Shapes> element

Contains a collection of Shape elements.

Syntax

 <Shapes>
</Shapes>

Attributes

 None.

Element information

 Parent elements: Page, Shape

Child elements: Shape (optional)

<ShowAlignBox> element

Specifies whether the selection rectangle is displayed when the shape is selected.

Value | Description
0 1 | Selection rectangle is not displayed. Selection rectangle is displayed.

Syntax

 <ShowAlignBox
[F = "formula"]
[Err = "error"]>
boolval
</ShowAlignBox>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 1 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Misc

Child elements: None

<ShowControlHandles> element

Specifies whether control handles are displayed when the shape is selected.

Value | Description
0 1 | Control handles are not displayed. Control handles are displayed.

Syntax

 <ShowControlHandles
[F = "formula"]
[Err = "error"]>
boolval
</ShowControlHandles>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 1 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Misc

Child elements: None

<ShowShapeHandles> element

Specifies whether selection handles are displayed when the shape is selected.

Value | Description
0 1 | Selection handles not displayed when the shape is selected. Selection handles are displayed when the shape is selected.

Syntax

 <ShowShapeHandles
[F = "formula"]
[Err = "error"]>
boolval
</ShowShapeHandles>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 1 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Misc

Child elements: None

<ShowText> element

Shows or hides the text of a shape.

Value | Description
0 1 | Text is hidden and is not printed. Text is not hidden.

Syntax

 <ShowText
[F = "formula"]
[Err = "error"]>
boolval
</ShowText>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 1 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Misc

Child elements: None

<Size> element

Specifies the size of the text in the shape's text block.

Syntax

 <Size
[F = "formula"]
[Err = "error"]>
shortval
</Size>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 8 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Character

Child elements: None

<SnapSensitivity> element

Shows the sensitivity of Snapping: the maximum distance between the snap locations and the shape for the snapping to be activated.

Syntax

 <SnapSensivity>
intval
</SnapSensivity>

Attributes

 None.

Element information

 Parent elements: DocumentSettings

Child elements: None

Remarks
The value is expressed in pixels and ranges within 1..32767.

<SnapSettings> element

Specifies the objects that shapes snap to when snap is enabled.
The bit values indicate that a specific snap setting is on or off. The value may be a sum of the following values:

Value | Description
0 1 2 4 8 16 32 64 128 256 512 1024 2048 4096 8192 16384 | Snap is disabled. Snap is enabled. Snap to ruler subdivisions. Snap to grid. Snap to guides. Snap to shape geometries. Snap to handles. Snap to vertices. Snap to connection points. Snap to smart guides is enabled. Snap to smart guides to geometries. Snap to smart guides to handles. Snap to smart guides to vertices. Snap to smart guides to connection points. Snap to smart guides to page center. Snap to smart guides to page diagonals .

Syntax

 <SnapSettings>
intval
</SnapSettings>

Attributes

 None.

Element information

 Parent elements: DocumentSettings

Child elements: None

<SplineKnot> element

Contains elements that specify information about a spline segment.
The X and Y elements specify the x- and y-coordinates of the spline ending vertex. The A and B elements specify the x- and y-coordinates of the spline guide point (control point).

Syntax

 <SplineKnot
[IX = "intval"]>
</SplineKnot>

Attributes

 IX
Optional int. The one-based index of the element within its parent element. If the index is not specified, it is obtained by incrementing the maximum index of the existing segments in the current geometry. If the given index already exists, all the child elements will modify the existing segment.

Element information

 Parent elements: Geom

Child elements: X (optional), Y (optional), A (optional), B (optional)

<SplineStart> element

Contains elements that specify information about a spline begining.
The X and Y elements specify the x- and y-coordinates of the spline begining vertex. The A and B elements specify the x- and y-coordinates of the spline guide point (control point).

Syntax

 <SplineStart
[IX = "intval"]>
</SplineStart>

Attributes

 IX
Optional int. The one-based index of the element within its parent element. If the index is not specified, it is obtained by incrementing the maximum index of the existing segments in the current geometry. If the given index already exists, all the child elements will modify the existing segment.

Element information

 Parent elements: Geom

Child elements: X (optional), Y (optional), A (optional), B (optional)

<Start> element

Contains the x- and y-coordinates of the first vertex in a path. It defines the so-called start segment of the geometry.

Syntax

 <Start
[IX = "intval"]>
</Start>

Attributes

 IX
Optional int. The one-based index of the element within its parent element. If the index is not specified, it is obtained by incrementing the maximum index of the existing segments in the current geometry. If the given index already exists, all the child elements will modify the existing segment.

Element information

 Parent elements: Geom

Child elements: X (optional), Y (optional)

Remarks
Contains the x- and y-coordinates of the first vertex for the shape if Start element is the first element in the first Geom element. Usually this is the first vertex placed when the shape was drawn, and it does not necessarily correspond to the begin point of a 1-D shape.
A Geom element must begin with a Start element.
The x- and y-coordinates are specified in the X and Y elements.

<Subject> element

Contains a user-defined text string that describes the contents of the document or library.

Syntax

 <Subject>
strval
</Subject>

Attributes

 None.

Element information

 Parent elements: DocumentProperties , Library

Child elements: None

<Text> element

Contains elements describing the parameters of the shape's text.

Syntax

 <Text>
</Text>

Attributes

 None.

Element information

 Parent elements: Shape

Child elements: Transform (optional), Paragraph (optional), Character (optional), TextBlock (optional), TheText (optional)

<TextBlock> element

Contains elements that specify the alignment, margins, and default tab stop positions of text in a shape's text block.

Syntax

 <TextBlock>
</TextBlock>

Attributes

 None.

Element information

 Parent elements: Text , DefaultSettings

Child elements: VAlign (optional), TopMargin (optional), BottomMargin (optional), TextBkgnd (optional), LeftMargin (optional), RightMargin (optional)

<TheText> element

Contains the text of a shape.

Syntax

 <TheText
[F = "formula"]
[Err = "error"]>
strval
</TheText>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> "text" </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Text

Child elements: None

<Title> element

Contains a user-defined text string that serves as a descriptive title for the document or library.

Syntax

 <Title
strval
</Title>

Attributes

 None.

Element information

 Parent elements: DocumentProperties

Child elements: None

<TopMargin> element

Specifies the distance between the top border of the text block and the first line of text it contains.

Syntax

 <TopMargin
[F = "formula"]
[Err = "error"]>
floatval
</TopMargin>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 8 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: TextBlock

Child elements: None

<Transform> element

Contains elements specifying general information concerning the position of a shape:
shape width, height, angle, and center of rotation (pin); the indication whether the shape has been flipped.

Syntax

 <Transform>
</Transform>

Attributes

 None.

Element information

 Parent elements: Shape , Text

Child elements: Width (optional), Height (optional), Angle (optional), GPinX (optional), GPinY (optional), FlipX (optional), FlipY (optional), LocPinX (optional), LocPinY (optional)

<UndoDepth> element

Determines the Undo depth for the document.

Syntax

 <UndoDepth>
intval
</UndoDepth>

Attributes

 None.

Element information

 Parent elements: DocumentSettings

Child elements: None

Remarks
ConceptDraw versions 1.x support the Undo depth ranging from 1 to 1000. If the value is not within this range, it is ignored, and the default value is preserved.

<Units> element

Identifies the measurement unit currently used in the document (by default). It can take one of the following values, excepting "InternalUnit":

Value | Abbreviation for use | Description
Yard Foot FootInch FootFractInch Inch FractInch Meter Cm Mm Km Mile Pix Point InternalUnit | YD FT F_I F_IF IN IN_F M CM MM KM MI PIX PT | Decimal yards. Decimal feet. Feet, decimal inches. Feet, fractional inches. Decimal inches. Fractional inches. Meters. Centimeters. Millimeters. Kilometers. Miles. Pixels. Points: 1 pt = 1/72 in. Internal measurement units: 1 = 0.1 mm

Syntax

 <Units>
enumval
</Units>

Attributes

 None.

Element information

 Parent elements: DocumentSettings

Child elements: None

Remarks
The current measurement units are used to present any numeric information for the document, which is displayed on therulers, in the status bar, etc. But the numeric characteristics of objects (coordinates, width and height) are expressed by default in the ConceptDraw universal internal measurement unit: 1 = 0.1 mm. For angles, the default unit is radians.

<VAlign> element

Specifies the vertical alignment of text within the text block.

Value | Description
0 1 2 | Top Middle Bottom

Syntax

 <VAlign
[F = "formula"]
[Err = "error"]>
byteval
</VAlign>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 8 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: TextBlock

Child elements: None

<Variable> element

Contains elements for one variable defined for the shape.

Syntax

 <Variable
[IX = "intval"]>
</Variable>

Attributes

 IX
Optional int. The one-based index of the element within its parent element.

Element information

 Parent elements: Variables

Child elements: X (optional), Y (optional)

<Variables> element

Contains a set of the Variable elements describing additional variables of the shape.

Syntax

 <Variables>
</Variables>

Attributes

 None.

Element information

 Parent elements: Shape

Child elements: Variable (optional)

<Visible> element

Specifies whether a path is displayed on the drawing page.

Value | Description
0 1 | The stroke and fill of the path represented by this section are hidden. The stroke and fill of the path are shown.

Syntax

 <Visible
[F = "formula"]
[Err = "error"]>
boolval
</Visible>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 1 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Geom

Child elements: None

<Width> element

Contains the width of the associated shape in drawing units.

Syntax

 <Width
[Unit = "unitval"]
[F = "formula"]
[Err = "error"]>
doubleval
</Width>

Attributes

Unit
Optional string. Represents the unit of measure in which the value is specified. It can take one of the values from the "Abbreviation for use" column from the table of the supported units of measure. The default value is the ConceptDraw internal measurement unit: 1 = 0.1 mm.
 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 8 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Transform

Child elements: None

<X> element

Specifies an x-coordinate on a shape in local coordinates. The following table describes the X element based on the element that contains it.

Element | Description of X element
Start LineTo ArcTo EllipseTo SplineStart SplineKnot Connection Control Variable | The X element represents the x-coordinates of the first vertex of a path. The X element represents the x-coordinates of the ending vertex of a straight line segment. The X element represents the x-coordinates of the ending vertex of a circular arc segment. The X element represents the x-coordinates of the ending vertex of a elliptical arc segment. The X element represents the x-coordinates of the spline begining vertex. The X element represents the x-coordinates of the spline ending vertex. The X element represents the x-coordinates of the connection point. The X element represents the x-coordinates of the control point. The X element represents the x-component of the variable.

Syntax

 <X
[Unit = "unitval"]
[F = "formula"]
[Err = "error"]>
doubleval
</X>

Attributes

Unit
Optional string. Represents the unit of measure in which the value is specified. It can take one of the values from the "Abbreviation for use" column from the table of the supported units of measure. The default value is the ConceptDraw internal measurement unit: 1 = 0.1 mm.
 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 8 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Start, LineTo, ArcTo, EllipseTo, SplineStart, SplineKnot, Connection, Control, Variable

Child elements: None

<XBehaviour> element

Determines how the control handle moves along the X axis when the object is resized.
The possible values of the element are listed in the following table:

Value | Description
0 | The control repositions proportionally with respect to the alignment box.
1 | The control point repositions proportionally with respect to the alignment box. The repositioning with the mouse along the X axis is locked.
2 | The distance to the left side of the alignment box remains constant.
3 | The distance to the centre of the alignment box remains constant.
4 | The distance to the right side of the alignment box remains constant.
5 | The control point is invisible. When resizing the object, the control point moves proportionally with respect to the alignment box.
6 | The control point is invisible. When the object is resized, the control point moves proportionally with respect to the alignment box. The repositioning with the mouse along the X axis is locked.
7 | The control point is invisible. When the object is resized, the distance to the left side of the alignment box remains constant.
8 | The control point is invisible. When the object is resized, the distance to the centre of the alignment box remains constant.
9 | The control point is invisible. When the object is resized, the distance to the right side of the alignment box remains constant.

Syntax

 <XBehaviour
[F = "formula"]
[Err = "error"]>
byteval
</XBehaviour>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 1 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Control

Child elements: None

Remarks
If there was a default formula in the X element, the program changes it according to the XBehaviour element value after the control point is repositioned.

<XDyn> element

Specifies the x-coordinate for a control handle's anchor point in local coordinates. The anchor point is used for rubber-banding during dynamics.

Syntax

 <XDyn
[F = "formula"]
[Err = "error"]>
doubleval
</XDyn>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 8 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Control

Child elements: None

<Y> element

Specifies an y-coordinate on a shape in local coordinates. The following table describes the Y element based on the element that contains it.

Element | Description of Y element
Start LineTo ArcTo EllipseTo SplineStart SplineKnot Connection Control Variable | The Y element represents the y-coordinates of the first vertex of a path. The Y element represents the y-coordinates of the ending vertex of a straight line segment. The Y element represents the y-coordinates of the ending vertex of a circular arc segment. The Y element represents the y-coordinates of the ending vertex of a elliptical arc segment. The Y element represents the y-coordinates of the spline begining vertex. The Y element represents the y-coordinates of the spline ending vertex. The Y element represents the y-coordinates of the connection point. The Y element represents the y-coordinates of the control point. The Y element represents the y-component of the variable.

Syntax

 <Y
[Unit = "unitval"]
[F = "formula"]
[Err = "error"]>
doubleval
</Y>

Attributes

Unit
Optional string. Represents the unit of measure in which the value is specified. It can take one of the values from the "Abbreviation for use" column from the table of the supported units of measure. The default value is the ConceptDraw internal measurement unit: 1 = 0.1 mm.
 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 8 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Start, LineTo, ArcTo, EllipseTo, SplineStart, SplineKnot, Connection, Control, Variable

Child elements: None

<YBehaviour> element

Determines how the control handle moves along the Y axis when the object is resized.
The possible values of the element are listed in the following table:

Value | Description
0 | The control repositions proportionally with respect to the alignment box.
1 | The control point repositions proportionally with respect to the alignment box. The repositioning with the mouse along the Y axis is locked.
2 | The distance to the left side of the alignment box remains constant.
3 | The distance to the centre of the alignment box remains constant.
4 | The distance to the right side of the alignment box remains constant.
5 | The control point is invisible. When resizing the object, the control point moves proportionally with respect to the alignment box.
6 | The control point is invisible. When the object is resized, the control point moves proportionally with respect to the alignment box. The repositioning with the mouse along the Y axis is locked.
7 | The control point is invisible. When the object is resized, the distance to the left side of the alignment box remains constant.
8 | The control point is invisible. When the object is resized, the distance to the centre of the alignment box remains constant.
9 | The control point is invisible. When the object is resized, the distance to the right side of the alignment box remains constant.

Syntax

 <YBehaviour
[F = "formula"]
[Err = "error"]>
byteval
</YBehaviour>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 1 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Control

Child elements: None

Remarks
If there was a default formula in the Y element, the program changes it according to the XBehaviour element value after the control point is repositioned.

<YDyn> element

Specifies the y-coordinate for a control handle's anchor point in local coordinates. The anchor point is used for rubber-banding during dynamics.

Syntax

 <YDyn
[F = "formula"]
[Err = "error"]>
doubleval
</YDyn>

Attributes

 F
Optional string. Represents the element's formula. This attribute can contain the string "formula" if the formula exists locally.
If the attribute is not present, the element's formula is a simple constant, for example, <element> 8 </element>.
Err
Optional string. Indicates that the formula evaluates to an error. The value of Err is the current value (an error message string); the value of the element is the last valid value.

Element information

 Parent elements: Control

Child elements: None